Hisense H65U8B Bootet nicht, standby blinkt kurz beim Anstecken und bleibt dann rot

Diskutiere Hisense H65U8B Bootet nicht, standby blinkt kurz beim Anstecken und bleibt dann rot im Forum Reparatur von LCD Plasma Fernsehern sowie Beamer im Bereich Reparaturtips braune Ware - Ich bin neu hier im Forum und ich will mal meine Erkenntnisse zu einem Hisense H65U8B teilen. Ich habe das Teil defekt für kleines Geld erstanden...
A

afiftyp

Neuling
Registriert
27.05.2024
Beiträge
1
Punkte Reaktionen
0
Wissensstand
Bastler mit Reparaturerfahrung
  • Hisense H65U8B Bootet nicht, standby blinkt kurz beim Anstecken und bleibt dann rot
  • #1
Hersteller
Hisense
Typenbezeichnung
H65U8B
Kurze Fehlerbeschreibung
Bootet nicht, standby blinkt kurz beim Anstecken und bleibt dann rot
Meine Messgeräte
  1. Analog/Digital Voltmeter
  2. Oszilloskop
Schaltbild vorhanden?
Nein
Ich bin neu hier im Forum und ich will mal meine Erkenntnisse zu einem Hisense H65U8B teilen. Ich habe das Teil defekt für kleines Geld erstanden weil das Panel ohne schaden ist.
Laut Vorbesitzer lies es sich plötzlich nicht mehr einschalten und ich dachte schon es könnte der Einfachheit halber das Netzteil sein; das war es natürlich nicht.

Beim Anstecken hat die standby LED einmal rot geblinkt und ist dann an geblieben. Keine wertere Reaktion auf die Fernbedienung oder den Knopf am FS.

Ich habe dann mal aufgeschraubt und die Spannungen am Ausgang des Netzteils kontrolliert, die waren aber alle OK.

Als Nächstes habe ich, nach Recherche im Internet an die serielle Service Schnittstelle, 3.5mm Klinke, mit 115200 Baud angehängt und immerhin eine uboot Ausgabe bekommen, siehe Anhang uboot.txt. Gestört hat mich da gleich mal die Zeile
eMMC_RPMB_Read_data fail!
und am Ende die Message
worauf keine weiteren Ausgaben mehr erfolgen. Laut Internet muss bei Hisense die serielle Schnittstelle in einem Factory Menu an Bildschirm freigegeben werden.
Da komm ich natürlich nicht hin weil das Ding ja nicht bootet.

Nach längerer Recherche und suchen habe ich versucht den eMMC Speicher per OdroidC2 und dessen freier "SDIO" Schnittstelle auszulesen. Ich habe dazu den Quarz der CPU auf Masse gelegt so dass diese nicht loslaufen kann. Vom eMMC habe ich D0, CLK, und CMD an die passenden Pins am C2 geklemmt, und dann Mainboard an power und Odroid gestartet. Zur positiven Überaschung war das eMMC inclusive beider BOOT und des RPMB devices sichtbar.
Ich habe dann eine Sicherung des eMMC und der BOOT Blöcke gezogen.

Anschließend habe ich dann mittels der "strings" und "grep" Kommandos nach "uart" im Image gesucht und bin bei
fündig geworden. Bei genauerer Untersuchung mit "hexedit" war dann zu sehen dass dieseswohl die Einstellung für das uboot environment ist.
Ich habe es dann im Image auf "on" gepatched und zurückgeschrieben.

Tatsächlich hatte meine Änderung wohl bewirkt, dass uboot das environment vermutlich wegen fehlerhafter Checksumme nich mehr geladen hat und mit einen default geatarted ist. Aber immerhin war der Service Port dann gesprächiger und ich habe einen "<< MStar >>#" command prompt bekommen über den Kommandos gegeben werden können. Anschließend habe ich Schritt für Schritt das ursprünglche uboot Environment wiederhergestellt und abgespeichert.

Nach dem nächsten power cycle ist der "eMMC_RPMB_Read_data fail!" Fehler immer noch da und es wird auf USB nach installierbarer SW gesucht.
Ich habe mir dann vom freundlichen Hisense Service unter Angabe von Typ und Seriennummer den Like für die aktuelle SW schicken lassen.
Anschließend wurde diese SW zwar installiert, aber anstatt zu booten started die Installation immer wieder von vorne.
Ohne USB Stick wird auch nicht gebootet und ich lande auf dem uboot command prompt.

Meine Vermutung ist jetzt, dass das Problem wohl ursächlich mit dem Fehler bein Lesen des RPMB zusammenhängt. Am Odroid C2 konnte ich den RPMB block zwar physisch lesen "mmc rpmb read-counter ....", "mmc rpmb rpmb-read ....", aber den Schlüssel kenne ich halt nicht.
Schön wäre es wenn der Fernseher wenigstens booten würde so dass der DVB/T2/S2 und HDMI input funktioniert, aktuell ist er nutzlos.

Hisense hätte gerne ca. 170€ für ein neues board. Ich bin noch am Überlegen ob ich mir ein neues eMMC besorge aber vermutlich gibt es da einen factory prozess um den RPMB key zu erzeugen und zu speichern. Die Erfolgssaugsicht ist wohl eher gering.

Aber vielleicht hat ja hier jemand die rettende Idee.
Danke schon mal!
 

Anhänge

  • uboot.txt
    1,3 KB · Aufrufe: 16
  • uboot_neu.txt
    3,9 KB · Aufrufe: 15
  • MainBoard.JPG
    MainBoard.JPG
    550,1 KB · Aufrufe: 27
Thema: Hisense H65U8B Bootet nicht, standby blinkt kurz beim Anstecken und bleibt dann rot
Zurück
Oben